Description
This article explains how to save network logs in web development tools and the console logs from the browser and how to capture and read client side response trace with HAR file analyzer.
Environment:
Internet Explorer browser
Google Chrome browser
Mozila FireFox browser
Cause
Useful when troubleshooting Web applications.
Resolution
Google Chrome:
Open developer tools (Menu > More tools > Developer tools or
Ctrl + Shift + I
orF12
)Select the Network tab.
Make sure that "Preserve log" is checked so that all traffic is captured.
Access or refresh the page traffic needs to be captured for or a problem should be reproduced in
Perform the steps to cause the behavior/issue
Click on the down arrow "Export HAR..." button or Right-click within the Network capture pane then choose '
Save as HAR with content
' and save the .har capture locally.Click on the Console tab > right-click > Save As > Save on the .log file.
To Analyze the HAR file, the easiest tool will be the HAR Analyzer: https://toolbox.googleapps.com/apps/har_analyzer/
Firefox (41+) :
Go to Menu > Web Developer > Network
Reload the page you want to get the log for
Perform the steps to cause the behavior/issue
Right click > Save All as HAR
Click on Console tab > Select All
Right-Click > Copy Message, and paste it / save on a .txt file.
Internet Explorer:
Open Developer Tools (F12)
Go to the network tab and click on the green arrow to start the tool
Refresh the page to capture the logs
Perform the steps to cause the behavior/issue
Click 'Export captured traffic' icon and choose XML or HAR format.
Click on Console tab > right-click > Copy All, and paste it / save on a .txt file.
To Analyze the HAR file, the easiest tool will be the HAR Analyzer: https://toolbox.googleapps.com/apps/har_analyzer/