Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Description

This article explains how to save network logs (HAR/XML file) in web development tools and the console logs from the browser and how to capture and read the client side response trace with a HAR file analyzer. This is useful when troubleshooting web applications.

EnvironmentSteps to take differ according to the browser:

  • Internet Explorer browser

  • Google Chrome browser

  • Mozila FireFox browser

Cause

Useful when troubleshooting Web applications.

Resolution

Google Chrome:

...

Table of Contents
excludeHAR Analysis

This article is based on this source: https://support.qlik.com/articles/000016292

Google Chrome

  1. Open Developer tools (in Menu > More tools > Developer tools or or use Ctrl+Shift+I  or or F12).

  2. Select the Network tab.

  3. Make sure that "Preserve log" the ‘Preserve log’ option is checked so that all traffic is captured.

  4. Access or refresh the page for which traffic needs to be captured for or where a problem should be reproduced in.

  5. Perform the steps which lead to cause the behavior/issue.

  6. Click on the down arrow "Export the download icon ‘Export HAR..." button or Rightright-click within the Network capture pane then and choose 'Save as HAR with content' and save the .har capture locally.

    Image Added

  7. Click on On the Console tab > , right-click > Save As > Save on , select ‘Save as’ and save the .log file.

...

To Analyze the HAR file, the easiest tool will be the HAR Analyzer: https://toolbox.googleapps.com/apps/har_analyzer/

Firefox (41+)

...

  1. Go to Menu > Web Developer > Network.

  2. Reload the page you want to get the log for.

  3. Perform the steps which lead to cause the behavior/issue.

  4. Right-click > Save and select ‘Save All as HARHAR’.

  5. Click on the Console tab > Select Alland select ‘Select All’.

  6. Right-Click > Copy Message, and paste it / save on click, select ‘Copy Message’ and save it as a .txt file.

...

Internet Explorer

...

  1. Open Developer Tools (F12).

  2. Go to the network Network tab and click on the green arrow to start the tool.

  3. Refresh the page to capture the logs.

  4. Perform the steps which lead to cause the behavior/issue.

  5. Click the 'Export captured traffic' icon and choose XML or HAR format.

  6. Click on On the Console tab > , right-click > Copy All, and paste it / save on and select ‘Copy All’ and save it as a .txt file.

...

HAR Analysis

To Analyze analyze the HAR file, it is the easiest tool will be the to use HAR Analyzer: https://toolbox.googleapps.com/apps/har_analyzer/Source: https://support.qlik.com/articles/000016292