...
Data gathering functions should use a common prefix. This will significantly help when identifying performance problems. Remember that each function should do only do one thing at a time = : either gather data or manipulate the data somehow, ; do not mix these two.
Proposal:
- Functions that are querying Price Builder PriceBuilder (= calling functions api.find() or api.findLookupTableValues()) use the prefix "find" , e.g. findSalesOrgs().
- Functions that are querying Price Analyzer PriceAnalyzer (= calling executeQuery or executeSqlQuery)) use the prefix "load" , e.g. loadTransactions().
DF/DS/DM Fields
...